
PRACTICE PAPER–2
Max. Time: 2 Hours� Max. Marks: 50

General Instructions:
	1.	 Please read the instructions carefully.
	2.	 This Question Paper consists of 21 questions in two sections: Section A & Section B.
	3.	 Section A has Objective type questions whereas Section B contains Subjective type questions.
	4.	 Out of the given (5 + 16 = 21) questions, a candidate has to answer (5 + 10 = 15) questions in the allotted (maximum) 

time of 2 hours.
	5.	 All questions of a particular section must be attempted in the correct order.
	6.	 SECTION A—OBJECTIVE TYPE QUESTIONS (24 Marks):
			  (a)	 This section has 05 questions.
			  (b)	 Marks allotted are mentioned against each question/part.
			   (c)	 There is no negative marking.
			  (d)	 Do as per the instructions given.
	7.	 SECTION B—SUBJECTIVE TYPE QUESTIONS (26 Marks):
			  (a)	 This section has 16 questions.
			  (b)	 A candidate has to do 10 questions.
			   (c)	 Do as per the instructions given. 
			  (d)	 Marks allotted are mentioned against each question/part.

SECTION A—OBJECTIVE TYPE QUESTIONS 

	 1.	 Answer any 4 out of the given 6 questions on Employability Skills.� (1 × 4 = 4 marks)

			   (i)	 Rita’s teacher asks her to come to the front of the class. Without saying a word, Rita nods her head to show 
agreement. Which of the following forms of communication is Riya using?� (1)

					     (a)	 Email	 (b)	 Gesture	 (c)	 Telephone	 (d)	 Letter

			  (ii)	 Amish feels overwhelmed with multiple deadlines and forgets to prioritize his work. Which self-management 
technique can help him?� (1)

					     (a)	 Ignoring tasks			   (b)	 Time management
					     (c)	 Avoiding teamwork			   (d)	 Daydreaming

			  (iii)	 Shama has downloaded a new photo editing software but it doesn’t open because her operating system  
version is outdated. Which OS function is responsible for ensuring software compatibility?� (1)

					     (a)	 File management			   (b)	 Device management
					     (c)	 Memory management			   (d)	 Software management

			  (iv)	 ................................................ is an example of an entrepreneur.			   (1)
					     (a)	 A person who works in a bank
					    (b)	 A person who runs his own bakery shop
					     (c)	 A person who teaches in a school
					    (d)	 A person who works in a government office

			  (v)	 Which of the following Sustainable Development Goals (SDGs) aims to promote decent work and  
economic growth?� (1)

					     (a)	 SDG 5	 (b)	 SDG 12	 (c)	 SDG 8	 (d)	 SDG 3

			  (vi)	 Which of the following is a key aspect of self-awareness?� (1)
					     (a)	 Relying on others for self-reflection
					    (b)	 Avoiding self-reflection
					     (c)	 Understanding personal values and beliefs
					    (d)	 Ignoring personal strengths and weaknesses



	 2.	 Answer any 5 out of the given 6 questions.� (1 × 5 = 5 marks)
			   (i)	 While working on a brochure, Devika uses different styles for titles, subtitles and body text. Later, her 

teacher asks her to ensure uniformity and quickly apply these predefined styles to select text portions.  
Which option should she use and from which menu can it be accessed?� (1)

					     (a)	 Fill Format Mode (from Styles → Manage Styles)
					    (b)	 Track Changes (from Edit → Track Changes)
					     (c)	 Comments (from Insert → Comment)
					    (d)	 TOC (Table of Contents) (from Insert → Table of Contents and Index)
			  (ii)	 Raman is creating a school project report in LibreOffice Writer and wants each page to show its page  

number automatically at the bottom. Which option should he use to insert the page number?� (1)
					     (a)	 Insert → Field → Page Number	 (b)	 Tools → Options
					     (c)	 Format → Styles			   (d)	 Table → Insert
			  (iii)	 Ivaan inserted a Table of Contents in his project report but later added a few new headings to the  

document. He wants the ToC to include the newly added headings. Which option should he use from the 
Insert → Table of Contents and Index menu to update it?� (1)

					     (a)	 Update Index			   (b)	 Refresh Document
					     (c)	 AutoFormat			   (d)	 Update All Fields
			  (iv)	 Assertion (A): The Track Changes option in Calc is useful when multiple users edit the same spreadsheet.

(1)
				    Reason (R): It automatically highlights all changes made, showing the editor’s name, date and type of  

change.
					     (a)	 Both A and R are true and R is the correct explanation of A.
					    (b)	 Both A and R are true but R is not the correct explanation of A.
					     (c)	 A is true but R is false.
					    (d)	 A is false but R is true.
			  (v)	 A store manager maintains a list of sales that includes columns for Sales_Person, Region and Amount. He 

wants Calc to automatically insert a total after each region’s sales data. What must he do before using the 
Subtotals feature?� (1)

					     (a)	 Sort the data by Region			   (b)	 Use Conditional Formatting
					     (c)	 Create a Pivot Table			   (d)	 Apply AutoFilter
			  (vi)	 Which of the following menu path in LibreOffice Calc is used to protect a worksheet?� (1)
					     (a)	 Tools → Protect Sheet			   (b)	 File → Save As
					     (c)	 Insert → Password			   (d)	 Data → Validate

	 3.	 Answer any 5 out of the given 6 questions.� (1 × 5 = 5 marks)
			   (i)	 Ayushi has created multiple project reports for her company. She wants all reports to have the same  

header, footer and predefined formatting automatically applied whenever a new file is created. However, 
when she opens a new document, the desired layout does not appear. Which of the following is the MOST 
likely reason for this issue?� (1)

					     (a)	 She did not set the created template as the default template.
					    (b)	 She saved the file with a different name instead of using ‘Save As Template’.
					     (c)	 She forgot to enable AutoText in the document.
					    (d)	 She did not update the style definitions before closing the file.
			  (ii)	 During routine maintenance, an office supervisor notices several loose wires near the employees’ desks and 

an overloaded power extension board connected to multiple devices. Which hazards are most relevant in 
this situation?� (1)

					     (a)	 Electrical and Fire Hazards		 (b)	 Ergonomic and Physical Hazards
					     (c)	 Chemical and Biological Hazards	 (d)	 Health and Mechanical Hazards
			  (iii)	 Which key uniquely identifies each record in a table?� (1)
					     (a)	 Foreign Key			   (b)	 Candidate Key
					     (c)	 Primary Key			   (d)	 Alternate Key
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			  (iv)	 A database designer creates a field named Emp_Name using the data type CHAR(30). When the user  
enters a name with only 15 characters, how much storage space will be used?� (1)

					     (a)	 15 bytes	 (b)	 18 bytes	 (c)	 30 bytes	 (d)	 42 bytes
			  (v)	 A school database stores student details in one table and class information in another. The database 

administrator wants to link both tables so that each student record can be connected to its respective class. 
Which feature should be used to establish this connection?� (1)

					     (a)	 Primary Key	 (b)	 Foreign Key	 (c)	 Unique Constraint	 (d)	 Default Value
			  (vi)	 Which object in Base is used to present data in a printed format?� (1)
					     (a)	 Query	 (b)	 Report	 (c)	 Table	 (d)	 Form

	 4.	 Answer any 5 out of the given 6 questions.� (1 × 5 = 5 marks)
			   (i)	 Which keyboard shortcut is used to open the Styles window in LibreOffice Writer to apply or modify  

styles?� (1)
					     (a)	 F11	 (b)	 Ctrl + Shift + S	 (c)	 Ctrl + Alt + F	 (d)	 Shift + F11
			  (ii)	 Mishika is calculating the monthly instalment (EMI) for a house loan in LibreOffice Calc. She fixes the loan 

amount and interest rate but wants the EMI to be exactly ₹50,000 per month by adjusting only the loan 
duration. Which feature should she use to find the required duration automatically?� (1)

					     (a)	 Scenario Manager with different loan durations
					    (b)	 Goal Seek to set EMI as the target value
					     (c)	 Subtotals to calculate total payments
					    (d)	 Consolidate to summarize loan data
			  (iii)	 Which of the following statements is incorrect regarding reports in Base?� (1)
					     (a)	 Reports can be printed directly.	 (b)	 Reports allow data entry.
					     (c)	 Reports can include headers and footers.	 (d)	 Reports are used for summarizing data.
			  (iv)	 During a routine inspection, it was found that several employees had strained eyes and frequent headaches 

due to improper monitor brightness and poor lighting. Which approach is most effective in reducing this 
hazard?							       (1)

					     (a)	 Conduct only monthly safety drills
					    (b)	 Adjust screen brightness and improve workplace lighting
					     (c)	 Provide more chairs and tables
					    (d)	 Increase working hours to complete pending tasks
			  (v)	 Anayra and her teammates are working on the same spreadsheet in LibreOffice Calc. The manager wants 

to review what changes each person has made before finalizing the report. Which feature should Anayra  
enable to keep track of all modifications made by different users?� (1)

					     (a)	 Track Changes	 (b)	 Scenario Manager	 (c)	 Goal Seek	 (d)	 Data Validation
			  (vi)	 Paper files and wooden objects are kept close to a heater in an office. These materials belong to which  

class of fire?� (1)
					     (a)	 Class A – Ordinary combustibles such as wood, paper and cloth
					    (b)	 Class B – Flammable liquids such as petrol and oil
					     (c)	 Class C – Electrical fires
					    (d)	 Class D – Fires involving metals like magnesium and sodium

	 5.	 Answer any 5 out of the given 6 questions.� (1 × 5 = 5 marks)
			   (i)	 Rohit designs a newsletter that will be published every month. He wants all newsletters to have the same 

layout, including a header, footer and predefined styles for titles and text. Which feature of LibreOffice 
Writer should he use to maintain a consistent design across all editions?� (1)

					     (a)	 Styles	 (b)	 Macros	 (c)	 Templates	 (d)	 Table of Contents
			  (ii)	 When creating a new table in LibreOffice Base using Table Wizard, which of the following can the user select 

from predefined options?� (1)
					     (a)	 Field names and data types	 (b)	 Font size and color
					     (c)	 Page layout settings			   (d)	 Macros and Styles
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			  (iii)	 While checking the server room, Mayank notices a burning smell coming from a power socket. He  
immediately switches off the main supply to prevent a ................................................ hazard.� (1)

					     (a)	 physical	 (b)	 fire	 (c)	 biological	 (d)	 chemical

			  (iv)	 While working in the office, Ankit notices that his coworker has received an electric shock and has fallen  
on the floor. Which sequence of actions demonstrates the correct response according to safety 
procedures?							       (1)

					     (a)	 Switch off the main power → call for medical help → inform the supervisor
					    (b)	 Call the supervisor → continue work → report at the end of the day
					     (c)	 Try to pull the person away from the wire with bare hands
					    (d)	 Leave the area immediately without informing anyone

			  (v)	 Vikram works in an office where papers, wires and coffee spills are often found on the floor. To ensure safety 
and prevent accidents, which combination of actions should he take?� (1)

					     (a)	 Ignore minor spills and wait for cleaning staff to handle them
					    (b)	 Clean spills immediately, keep walkways clear, and report damaged equipment
					     (c)	 Focus only on his own table and avoid common areas
					    (d)	 Switch off all lights and leave the area

			  (vi)	 A company maintains monthly sales data in four different spreadsheets—North.ods, South.ods, 
East.ods and West.ods. Before the quarterly meeting, the sales analyst wants to create a single 
summary sheet showing total sales from all regions. He also wants any future changes in regional sheets  
to be automatically updated in the summary sheet. Which steps should he follow in LibreOffice Calc?� (1)

					     (a)	 Use Pivot Table to summarize data from all sheets manually.
					    (b)	 Use Data Consolidate and enable the ‘Link to source data’ option to auto-update totals.
					     (c)	 Copy and paste the totals from each sheet into one summary sheet.
					    (d)	 Use Subtotals to calculate combined sales for each region.

SECTION B—SUBJECTIVE TYPE QUESTIONS

Answer any 3 out of the given 5 questions on Employability Skills in 20–30 words each.� (2 × 3 = 6 marks)

	 6.	 Describe the types of communication barriers.� (2)

	 7.	 Akshat often misses project deadlines because he doesn’t plan his daily tasks properly. Suggest two steps he can 
take to improve his time management skills.� (2)

	 8.	 ‘Entrepreneurship significantly impacts society in many ways.’ Discuss.� (2)

	 9.	 Explain the importance of Sustainable Development Goals.� (2)

	 10.	 Meena frequently downloads free software and email attachments from unknown sources. What steps  
should she follow to keep her computer system safe from malware and viruses?� (2)

Answer any 4 out of the given 6 questions in 20–30 words each.� (2 × 4 = 8 marks)

	 11.	 Manvi is learning to create professional documents in LibreOffice Writer. Her teacher asks her to explain  
what a Template is and mention any two advantages of using templates. What should Manvi write?� (2)

	 12.		 (a)	 What do you understand by cell reference? � (2)
			  (b)	 What is the purpose of Scenarios in Calc?

	 13.	 Differentiate between a primary key and a foreign key in a database?� (2)

	 14.	 Mention any four commonly occurring accidents in organizations. Suggest one safety measure to prevent  
them.� (2)

	 15.	 Can workbooks be linked in LibreOffice Calc? Linking workbooks also has certain drawbacks. Mention any  
two such drawbacks.� (2)

	 16.	 Vikram notices that his eyes feel tired after using the computer for long periods in dim light. Suggest any four 
ways he can reduce eye strain and maintain good eye health while working. � (2)
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Answer any 3 out of the given 5 questions in 50–80 words each.� (4 × 3 = 12 marks)

	 17.	 Case Study			   (4)
		  Anvi is helping her college design the Annual Report using LibreOffice Writer. She wants the document to  

look professional, consistent and easy to update. While working, her team faces the following challenges:
			   •	 The headings and subheadings are not consistent across all pages.
			   •	 The HOD wants all section titles in the same color, size and font style.
			   •	 The faculty suggests using predefined formatting for quick changes in appearance.
			   •	 Later, Anvi wants to ensure that any changes made to a style are automatically reflected throughout  

the document.
			  (a)	 Which feature should Anvi use to ensure consistent formatting across headings and subheadings?
			  (b)	 Which style category should she apply to format section titles?
			  (c)	 Which tool or window can she use to quickly apply or modify predefined styles?
			  (d)	 How can Anvi make sure that when she modifies a style, the change is applied to all the text using that  

style throughout the document?

	 18.	 Consider the table given below and answer the questions that follow:� (4)
Emp_ID Name Department Salary

E01 Ajay Saini HR ` 30000

E02 Meena Rajput IT ` 35000

E03 Rakesh Pathak Sales ` 25000

E04 Ajay Tiwari IT ` 49000

E05 Dhruv Goel Sales ` 35000

			  (a)	 Name all the fields in the given table.
			  (b)	 Which field should be made the primary key?
			  (c)	 Identify the field that can serve as an alternate key. Justify your answer.
			  (d)	 How many attributes and records are present in the given table?

	 19.	 Reena spends long hours working on the computer. Recently, she has started feeling pain in her neck 
and lower back due to her sitting posture and chair position. Suggest any four ways Reena can avoid  
musculoskeletal problems while working on the computer.� (4)

	 20.	 Rohan is creating a database in LibreOffice Base for his school’s Library Management System. He has two  
tables—Members (Member_ID, Name, Class, Contact_No) and Issued_Books (Issue_ID, Member_ID,  
Book_Title, Issue_Date, Return_Date).			   (4)

			  (a)	 Which field in both tables can be used to establish a relationship between Members and Issued_Books?
			  (b)	 What type of key is Member_ID in the Issued_Books table, and why is it required?
			  (c)	 Rohan wants to ensure that a book cannot be issued to a non-existent member. Which database rule  

should he apply?
			  (d)	 If Rohan sets the relationship between Members and Issued_Books as ‘One-to-Many’, explain what it  

means, citing an example.

	 21.	 Ms. Neha, the Finance Officer at Info Enterprises, has prepared a spreadsheet in LibreOffice Calc containing 
quarterly expense reports in different worksheets for various departments. She wants to analyze the overall 
expenditure and easily access related files for reference. Help her by answering the following questions:� (4)

			  (a)	 Which tool in Calc can be used to consolidate expense data from multiple department sheets into a  
single summary sheet?

			  (b)	 Name the Menu Option and Sub-Menu Option that can be used to perform this consolidation.
			  (c)	 Name the function that can be used to calculate the total expenditure for the entire year.
			  (d)	 She wants to open a reference file stored in another folder directly by clicking a text in a cell. How can  

this be achieved?
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